Wednesday 15 January 2014

On 22:51 by Unknown in    1 comment


Hello folks, this is my first post. M gonna explain about Pat and will give configuration for it with an example below. Port Address Tranlation is also called porting, port overloading, port-level multiplexed NAT and single address NAT. Port Address Translation (PAT), is an extension to network address translation (NAT) that permits multiple devices on a local area network (LAN) to be mapped to a single public IP address. The goal of PAT is to conserve IP addresses.Most home networks use PAT. In such a scenario, the Internet Service Provider (ISP) assigns a single IP address to the home network's router. When Computer X logs on the Internet, the router assigns the client a port number, which is appended to the internal IP address. This, in effect, gives Computer X a unique address. If Computer Z logs on the Internet at the same time, the router assigns it the same local IP address with a different port number. Although both computers are sharing the same public IP address and accessing the Internet at the same time, the router knows exactly which computer to send specific packets to because each computer has a unique internal address.




Configuration of router0
Router>enable
Router#config t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#interface fa0/0
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shut

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#exit
Router(config)#interface se2/0
Router(config-if)#ip address 200.1.1.1 255.255.255.248
Router(config-if)#no shut

%LINK-5-CHANGED: Interface Serial2/0, changed state to down
Router(config-if)#clock rate 64000
Router(config-if)#exit
Router(config)#
%LINK-5-CHANGED: Interface Serial2/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0, changed state to up

Router(config)#ip route 0.0.0.0 0.0.0.0 se2/0
Router(config)#interface fa0/0
Router(config-if)#ip nat inside
Router(config-if)#exit
Router(config)#interface se2/0
Router(config-if)#ip nat outside
Router(config-if)#exit
Router(config)#ip nat pool public 200.1.1.3 200.1.1.3 netmask 255.255.255.248
Router(config)#access list 1 permit 192.168.1.0 0.0.0.255
                      ^
% Invalid input detected at '^' marker.
               
Router(config)#access-list 1 permit 192.168.1.0 0.0.0.255
Router(config)#ip nat inside source list 1 pool public overload
Router(config)#exit

%SYS-5-CONFIG_I: Configured from console by console
Router#
Router#show ip nat translations
Pro  Inside global     Inside local       Outside local      Outside global
tcp 200.1.1.3:1025     192.168.1.2:1025   170.1.1.2:80       170.1.1.2:80
tcp 200.1.1.3:1024     192.168.1.3:1025   170.1.1.2:80       170.1.1.2:80
tcp 200.1.1.3:1026     192.168.1.5:1025   170.1.1.2:80       170.1.1.2:80
tcp 200.1.1.3:1027     192.168.1.6:1027   170.1.1.2:80       170.1.1.2:8


Configuration of router0
Router>enable
Router#config t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#interface fa0/0
Router(config-if)#ip address 170.1.1.1 255.255.0.0
Router(config-if)#no shut

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#exit
Router(config)#interface se2/0
Router(config-if)#ip address 200.1.1.2 255.255.255.248
Router(config-if)#no shut

%LINK-5-CHANGED: Interface Serial2/0, changed state to up

Router(config-if)#exit
















1 comment:

  1. truely progressive...gud stuff...great job Satnam..:)

    ReplyDelete