Saturday 1 February 2014

On 01:45 by Unknown in , , ,    No comments

Hello, this picture above is the situation. we will be doing everything on it step by step. So let's move on.


About Topology

Let me describe the whole situation for you guys. Four routers must be interconnected in a hub-and-spoke Frame Relay configuration. Router R1 is the hub, and routers R2, R3, and R4 are spoke routers. The Frame Relay connections will be established using Frame Relay point-to-point connections over subinterfaces from R1 to each spoke router. Routing will be established using static routes on the hub router and default routes on all spoke routers. The frame relay switch(es) have already been configured within the cloud. Remote administrative access is established using SSH with the username admin and password cisco. 

Some Important Objectives

  • You should View the default internetwork configuration.
  • You should Configure Frame Relay connectivity.
  • You should Configure Static and Default routing.
  • You should Verify connectivity.

Objective 1 : Configure Frame Relay and Static Routing on the Hub Router (R1).

Step 1. Verify Default Configurations.

let's first of all verify Default Configuration what it is.

  • Enter command at execution mode show running-config. it will show us preconfigured usernames and passwords, name etc etc. As shown below.

  • Now enter Show ip route command to check routing table.

we are did this to verify over default Configuration. Real work starts now.

Step 2. Configure the Physical Frame Relay Interface on R1.

Run following command on Router R1.


R1(config)# interface serial0/0/0
R1(config-if)# encapsulation frame-relay
R1(config-if)# no shutdown

This will enable frame-relay on physical interface.

Step 3. Configuring the Subinterfaces on R1.

R1(config)#interface s 0/0/0.102 point-to-point
R1(config-subif)#
%LINK-5-CHANGED: Interface Serial0/0/0.102, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0.102, changed state to up

R1(config-subif)#ip address 10.0.1.1 255.255.255.252
R1(config-subif)#frame-relay interface-dlci 102
R1(config-subif)#exit
R1(config)#interface s 0/0/0.103 point-to-point
R1(config-subif)#
%LINK-5-CHANGED: Interface Serial0/0/0.103, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0.103, changed state to up

R1(config-subif)#ip address 10.0.1.5 255.255.255.252
R1(config-subif)#frame-relay interface-dlci 103
R1(config-subif)#exit
R1(config)#interface s 0/0/0.104 point-to-point
R1(config-subif)#
%LINK-5-CHANGED: Interface Serial0/0/0.104, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0.104, changed state to up

R1(config-subif)#ip address 10.0.1.9 255.255.255.252
R1(config-subif)#frame-relay interface-dlci 104
R1(config-subif)#exit

Step 4. Configure Static Routing on R1 to reach the LANs of each spoke router.

R1(config)# ip route 10.20.20.0 255.255.255.0 10.0.1.2

R1(config)# ip route 10.30.30.0 255.255.255.0 10.0.1.6

R1(config)# ip route 10.40.40.0 255.255.255.0 10.0.1.10

After this in execution mode enter Show running configuration to view the configuration done. here it is:


You can see the changes clearly.

Objective 2: Configure Frame Relay and Default routing on the Spoke Routers.

Step 1. Configure the Physical Frame Relay Interface on the spoke routers.

R2(config-if)#interface se 0/0/0
R2(config-if)#encapsulation frame-relay
R2(config-if)#no shutdown

R2(config-if)#
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up

Step 2. Configure the Subinterfaces on R2.

R2(config)#interface Serial0/0/0.101 point-to-point
R2(config-subif)#
%LINK-5-CHANGED: Interface Serial0/0/0.101, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0.101, changed state to up

R2(config-subif)#ip address 10.0.1.2 255.255.255.252
R2(config-subif)#frame-relay interface-dlci 101
R2(config-subif)#exit
R2(config)#

Step 3. Configure Default Routing on R2.

R2(config)# ip route 0.0.0.0 0.0.0.0 10.0.1.1

Step 4. Configuring Routers R3 and R4.

We will use same steps as used in step no 1 to 3.

R3(config)#interface se 0/0/0 
R3(config-if)#encapsulation frame-relay
R3(config-if)#no shutdown

R3(config-if)#
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up

R3(config-if)#interface Serial0/0/0.101 point-to-point
R3(config-subif)#
%LINK-5-CHANGED: Interface Serial0/0/0.101, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0.101, changed state to up

R3(config-subif)#ip address 10.0.1.6 255.255.255.252
R3(config-subif)#frame-relay interface-dlci 101
R3(config-subif)#exit
R3(config)#ip route 0.0.0.0 0.0.0.0 10.0.1.5

R4(config)#interface se 0/0/0
R4(config-if)#encapsulation frame-relay
R4(config-if)#no shutdown

R4(config-if)#
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up

R4(config-if)#interface Serial0/0/0.101 point-to-point
R4(config-subif)#
%LINK-5-CHANGED: Interface Serial0/0/0.101, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0.101, changed state to up

R4(config-subif)#ip address 10.0.1.10 255.255.255.252
R4(config-subif)#frame-relay interface-dlci 101
R4(config-subif)#exit
R4(config)#ip route 0.0.0.0 0.0.0.0 10.0.1.9

That's it we are done. all links are green. that means our Configuration is ok.


  • Now let's verify Frame relay networks that we have created just recently. Enter following commands at R1.
  • show frame-relay map
Serial0/0/0.102 (up): point-to-point dlci, dlci 102, broadcast, status defined, active
Serial0/0/0.103 (up): point-to-point dlci, dlci 103, broadcast, status defined, active
Serial0/0/0.104 (up): point-to-point dlci, dlci 104, broadcast, status defined, active
  • show frame-relay lmi
LMI Statistics for interface Serial0/0/0 (Frame Relay DTE) LMI TYPE = CISCO
 Invalid Unnumbered info 0      Invalid Prot Disc 0
 Invalid dummy Call Ref 0       Invalid Msg Type 0
 Invalid Status Message 0       Invalid Lock Shift 0
 Invalid Information ID 0       Invalid Report IE Len 0
 Invalid Report Request 0       Invalid Keep IE Len 0
 Num Status Enq. Sent 26        Num Status msgs Rcvd 26
 Num Update Status Rcvd 0       Num Status Timeouts 16

LMI Statistics for interface Serial0/0/0.102 (Frame Relay DTE) LMI TYPE = CISCO
 Invalid Unnumbered info 0      Invalid Prot Disc 0
 Invalid dummy Call Ref 0       Invalid Msg Type 0
 Invalid Status Message 0       Invalid Lock Shift 0
 Invalid Information ID 0       Invalid Report IE Len 0
 Invalid Report Request 0       Invalid Keep IE Len 0
 Num Status Enq. Sent 0         Num Status msgs Rcvd 0
 Num Update Status Rcvd 0       Num Status Timeouts 16

LMI Statistics for interface Serial0/0/0.103 (Frame Relay DTE) LMI TYPE = CISCO
 Invalid Unnumbered info 0      Invalid Prot Disc 0
 Invalid dummy Call Ref 0       Invalid Msg Type 0
 Invalid Status Message 0       Invalid Lock Shift 0
 Invalid Information ID 0       Invalid Report IE Len 0
 Invalid Report Request 0       Invalid Keep IE Len 0
 Num Status Enq. Sent 0         Num Status msgs Rcvd 0
 Num Update Status Rcvd 0       Num Status Timeouts 16

LMI Statistics for interface Serial0/0/0.104 (Frame Relay DTE) LMI TYPE = CISCO
 Invalid Unnumbered info 0      Invalid Prot Disc 0
 Invalid dummy Call Ref 0       Invalid Msg Type 0
 Invalid Status Message 0       Invalid Lock Shift 0
 Invalid Information ID 0       Invalid Report IE Len 0
 Invalid Report Request 0       Invalid Keep IE Len 0
 Num Status Enq. Sent 0         Num Status msgs Rcvd 0
 Num Update Status Rcvd 0       Num Status Timeouts 16

  • show frame-relay pvc
R1# show frame-relay pvc
PVC Statistics for interface Serial0/0/0 (Frame Relay DTE)
DLCI = 102, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/0/0.102

input pkts 14055       output pkts 32795        in bytes 1096228
out bytes 6216155      dropped pkts 0           in FECN pkts 0
in BECN pkts 0         out FECN pkts 0          out BECN pkts 0
in DE pkts 0           out DE pkts 0
out bcast pkts 32795   out bcast bytes 6216155

DLCI = 103, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/0/0.103

input pkts 14055       output pkts 32795        in bytes 1096228
out bytes 6216155      dropped pkts 0           in FECN pkts 0
in BECN pkts 0         out FECN pkts 0          out BECN pkts 0
in DE pkts 0           out DE pkts 0
out bcast pkts 32795   out bcast bytes 6216155

DLCI = 104, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/0/0.104

input pkts 14055       output pkts 32795        in bytes 1096228
out bytes 6216155      dropped pkts 0           in FECN pkts 0
in BECN pkts 0         out FECN pkts 0          out BECN pkts 0
in DE pkts 0           out DE pkts 0
out bcast pkts 32795   out bcast bytes 6216155
  • Now ping PC2 and PC3. Bingo, ping is successfull, if not check your commands that you entered in previous steps.
  • From the R1 router, ping the LAN interfaces of routers R2, R3, and R4. You should be able to successfully ping.
Thanks for viewing. Don't forget to share or comment if you enjoyed it.
Stay tuned.

0 comments:

Post a Comment