Wednesday, 26 February 2014

Classful Network


let's first know little bit about classful network, what it is, how to implement it. A classful network is a network addressing architecture used in the Internet from 1981 until the introduction of Classless Inter-Domain Routing in 1993. The method divides the address space for Internet Protocol Version 4 (IPv4) into five address classes. Each class, coded in the first four bits of the address, defines either a different network size, i.e. number of hosts for unicast addresses (classes A, B, C), or a multicast network (class D). The fifth class (E) address range is reserved for future or experimental purposes.

Classful addressing, formally adopted as part of the Internet Protocol (IP) in RFC 791, was the Internet's first major addressing scheme. The IP address was 32 bits in size, just as today, but was managed considerably differently.

There were three address classes to chose from: A, B, or C, corresponding to 8-bit, 16-bit, or 24-bit prefixes. No other prefix lengths were allowed, and there was no concept of nesting a group of 24-bit prefixes, for example, within a 16-bit prefix.

ClassLeading
bits
Size of network
number
 bit field
Size of rest
bit field
Number
of networks
Addresses
per network
Start addressEnd address
Class A    0    8    24    128 (27)    16,777,216 (224)0.0.0.0127.255.255.255
Class B    10    16    16    16,384 (214)    65,536 (216)128.0.0.0191.255.255.255
Class C    110    24    8    2,097,152 (221)    256 (28)192.0.0.0223.255.255.255
Class D (multicast)    1110    not defined    not defined    not defined    not defined224.0.0.0239.255.255.255
Class E (reserved)    1111    not defined    not defined    not defined    not defined240.0.0.0255.255.255.255

Configure the routers with class full network with RIP1

Description: The Routing Information Protocol (RIP) is a distance-vector protocol that uses hop count as it’s metric. RIP is widely used for routing traffic in the global Internet and is an interior gateway protocol, which means that it performs routing within a single autonomous system. Using RIP, a gateway host (with a router) sends its entire routing table to its closest neighbour host every 30 seconds. The neighbour host in turn will pass the information on to its next neighbour and so on until all hosts within the network have the same knowledge of routing paths, a state known as network convergence. RIP uses a hop count as a way to determine network distance.

Solution: The given topology is:


Steps:
Configuring steps for router0:

Router>enable
Router#config t
Router(config)#interface fa0/0
Router(config-if)#ip address 10.0.0.1 255.0.0.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface se2/0
Router(config-if)#ip address 20.0.0.1 255.0.0.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#router rip
Router(config-router)#network 10.0.0.0
Router(config-router)#network 20.0.0.0
Router(config-router)#exit

Configuring steps for router1:

Router>enable
Router#config t
Router(config)#interface fa0/0
Router(config-if)#ip address 30.0.0.1 255.0.0.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface se2/0
Router(config-if)#ip address 20.0.0.2 255.0.0.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#router rip
Router(config-router)#network 20.0.0.0
Router(config-router)#network 30.0.0.0
Router(config-router)#exit

Configuring steps for router2:

Router>enable
Router#config t
Router(config)#interface fa0/0
Router(config-if)#ip address 50.0.0.1 255.0.0.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface se2/0
Router(config-if)#ip address 40.0.0.2 255.0.0.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#router rip
Router(config-router)#network 40.0.0.0
Router(config-router)#network 50.0.0.0
Router(config-router)#exit

Output:
Ping command from PC5 to PC1


0 comments:

Post a Comment